Hints & Tips



  Calculating User Scales:
The scales available in the Drawing Setup dialog are the most commonly used for most projects. But, what if you need a scale not listed. like 3/16"=1'0"? Turn it into a ratio and type it in as a User's Scale. Here's how.
Choose Drawing Setup from the Layout menu. Let's use the scale, 3/16" = 1'0". Multiply 16 by 12 to get 192. Then, divide 192 by 3 to get 64. The ratio equivalent of 3/16" = 1'0" is 1:64. Or you can make it even easier by performing the math calculations in the dialog box where you type in the scale. Simply type (16*12)/3 and press Enter.
 
  For Former ClarisCAD or other Users:
If you are used to using special keyboard commands in ClarisCAD, you can set the same key commands in PowerDraw and PowerCADD. Use the Commands function under the Layout menu to set and change key commands to those commands you are most familiar. PowerDraw and PowerCADD also allows you to print a list of all Keyboard commands set. A file named "Keyboard Commands" is created when you assign Commands and is in your PowerDraw or PowerCADD folder. Open this file within any word processing or spreadsheet program and print for a reference sheer.
 
  Dual Dimensioning with Metric & Imperial
Many users have expressed a need to have both Imperial and Metric dimensions on a drawing. Additionally, the ability to print only one type of dimension at a time is desired. Try this.

First, turn Edit All Layers OFF.

Set up two layers named: Dim Metric and Dim Imperial (feet & inches)

Ensure the settings for your Dimension tools are currently the desired feet & inches, decimal feet, etc. and the placement for the text is ABOVE.

* Activate the Dim Imperial layer
* Dimension all items required.
* Select All and Copy.
* Activate (move to) the Dim Metric layer
* Paste
* Select Edit from the Edit menu.
* Change Units to Meters and the Placement to BELOW and click OK.

You now have a drawing with accurate dual dimensioning. If you wish to print only Imperial dimensions, simply hide the Dim Metric layer before printing.
 
 

HPGL & Clipping
Recently, we were sent a test file which sparked some neat ideas for the Read HPGL option of the Translators.

The file started in AutoCAD as a 3D drawing. The 3D model was arranged to provide a 3/4 view similar to an isometric drawing. Once the view was set, the hidden lines were removed. Finally, the wireframe model was plotted to a disk file in HPGL format.

The test was to see if the HPGL file could be opened in PowerCADD for use as a pictorial view for other drawings. In short, the translation was very successful and the drawing looked great. It was fully editable, too. Colors could be changed, objects could be attached to provide polygon "surfaces" which could be filled to give a solid, rendered look.

This test also pointed out another neat trick. Suppose you have a drawing with lots of objects which have been masked by other white-filled objects. When you plot this file, the computer has to calculate for clipping-it has to figure out which part of the images drawn should be removed or "clipped" from the final plot. So what happens when you plot to disk and then read the resulting HPGL file back into PowerCADD? A clipped, clean, automatically-trimmed drawing!

If you have the Translators, experiment with different objects and then plot them to disk. Open the files again using the Read HPGL option and observe the changes. You will notice that the drawing comes in rotated due to the way files are sent to plotters. Reading plot files back into PowerCADD is also a good way to troubleshoot plotting problems; if the plot file matches the original drawing, you may have a hardware or system problem-if it doesn't match, the drawing itself may contain a corrupted object or something way off the page.

 
  Associative Dimensioning
Associative dimensioning is a term created by the CAD world. Basically, it means that when you resize a dimensioned object, the dimension will recalculate automatically-the dimension is associated with the object it is defining. There are two ways to do this in PowerDraw or PowerCADD. You can simply group the object with its dimension or use Move Points.

Grouping the object with its dimension is the easiest. Once grouped, simply stretch the group and the dimension will change, too. If the dimension must be on a separate layer, and in most cases they are, you can use Move Points.

With Move Points, you can select an area to be moved which contains "points" of intersection. For example, suppose you had a rectangle which was dimensioned on its long side. To lengthen it, you could use Move Points to select one end of the shape (a short side) and one end of the dimension to be moved at the same time. Once selected, you may drag the object to a new length or use the Move command and specify the distance very accurately. When the move is complete, the dimensions will be correct, too.

Experiment with each method of associating dimensions to find the right one for your needs.
 

 

DXF Do's and Don'ts

VERSION 11-17-97

Provided courtesy of Jerry Hastings

City of Los Angeles - Dept. of Rec. & Parks

AUTOCAD TRANSLATION PROCEDURE FOR CONSULTANTS

Follow these simple instructions to insure that the AutoCAD file you send will be successfully translated into our native CADD format (PowerCADD). Note that there are two file format options, DXF and DWG. Base your choice on whether or not your drawing contains blocks with attributes (i.e., blocks that prompt data input upon insertion). If your file does have blocks with attributes, save file as dxf. If not, save file as DWG. The procedure as given below assumes file will be saved as a dxf file. The procedure for creating a DWG file is identical, except do not set dxfout in preferences.

PROCEDURE FOR PREPARING AUTOCAD FILE TO SEND TO DEPARTMENT OF RECREATION AND PARKS:

1. Open file and save to a temporary file name for backup purposes.
2. Go into model space using tilemode 1 command.
3. Set layering to correct configuration.
4. Zoom extents and erase any extra entities until zoom extents command shows only the project drawing.
5. Set limits slightly outside of project drawing. Zoom all to check that limits are picked correctly.
6. Type xref, enter, ?. Number indicated should be 0. If any files are shown, use xref detach until number returned is 0.
7. Audit file with a request for fixing. Rerun audit until total errors found = 0.
8. Purge all. Continue to repeat this command until no un-referenced entities are found.
9. Save file.
10. Dxfout using appropriate accuracy.

CHECK PROCEDURE

1. Open blank AutoCAD drawing.
2. Dxfin dxf file created under No. 10 above.
3. Make a review of the layering, and drawing entities.
4. Make the following tests: Zoom all, zoom extents, xref, and audit. If results are different from that desired above reopen drawing file and correct, following steps 1-10 above.
5. Transmit file to the Department along with a layering configuration list. Note the following three options for transmitting file:
a. (Preferred) Transmit file via America OnLine or via Internet.
b. Copy file onto 3.5 inch floppy diskette and mail to Recreation & Parks. Note: if file is too large to fit on single diskette, use PKZIP, WINZIP or equivalent, to compress file and/or to segment, as necessary, across multiple diskettes.
c. Burn file or files onto CD-ROM disk and mail to Recreation & Parks.

DO'S

1. Do save the file in AutoCAD Release 11, 12, or 13.
2. Do use model space in tilemode 1, (not paper space).
3. Do set limits to slightly outside of project drawing.

DON'TS

1. Don't save file in Release 14.
2. Don't use paper space.
3. Don't send file with xref attachments. If you use xref, be sure to use xref detach before final save. Check to verify that nothing is listed as xref.
4. Don't save file as DWG if you used blocks with attributes, save as DXF.
5. Don't save any file as an exe, PowerCADD cannot open an executable file.

NOTE: Within AutoCAD release 14 is an object class known as ARX. At this time, its effect on the Department's translation software is unknown. Therefore, again, if you are using release 14, be sure to save back to release 13 or 12.

Note: the above information was graciously provided by Lewis Soloff, Soloff Surveying & Consulting.

Using Color:

* Use the Basic color palette for all pen colors.
* Use only the first eight colors (ignore white)

These are closer to the eight basic colors in AutoCAD.

Avoid white fills (opaque)

There is no equivalent hatch pattern for white fills in programs like AutoCAD. Therefore, the objects which have been masked by opaque white-filled polygons will "show through" when translated into DXF. To avoid the problems:
* Make sure all of your tools are set with no fill, including the Text and Leader tools. This will make it easier for you to see when you have overlapping areas.
*Trim the areas you would normally hide by using Clip, Combine, Trim/Extend, and so on.
*Use the Door/Window Insertion tools to place doors and windows in line-drawn walls. If filled polygon walls are used, cut openings in the walls using Cut with Line or the Break tool. Do not use white rectangles with no pen in your door and window symbols to 'cut' the opening.

Instructions for the DXF side

Our thanks to Robert Wease of entasisDESIGN, Inc. in their Indianapolis office for sending in the instructions they use to insure a successful translation. Communication with someone sending a DXF file for translating is extremely important. It can mean the difference between success and failure. The following steps can be immensely helpful.

1. Detach or turn off all "XREFS"
2. Never "DXF"..."ENTITIES ONLY"
3. Set drawing with a sheet size limits slightly larger than the area of all of the objects.
4. Send a Blueline, plot or any hard copy of the drawings.
5. Send a note of the scale and sheet size.

We welcome any tips or hints you may have discovered that may help others in translating.

 
  Hot Tip:
If you are experiencing "jerky" and slower-than-I expected operation of PowerCADD, check to see if you have MacTools. There have been reports that dumping them helps immensely.
 
  Symbols:
Symbols consisting of only one piece cannot be replaced using the Replace Symbol command if placed as a group. If you use one-piece symbols, always place as an instance.
 
  Using PowerPlot:
When printing with InfoWave's PowerPlot, always use the plain paper settings.